PCI Compliance and TLS 1.0 Update

by

Effective June 16th, 2018, StoreSecured will be turning off our support for TLS 1.0.    We are doing so to comply with the latest PCI standards which require that support for TLS1.0 is disabled by June 30, 2018 at the latest.

 

Potential Issues

Please note that if you or your clients have very old browsers this may mean that you are no longer able to use the StoreSecured website’s in secure mode unless the browser is upgraded.

How to check your browser

Go to https://www.ssllabs.com/ssltest/viewMyClient.html and look in the very first box labelled Protocol Support.  If it says “Your user agent has good protocol support” then you are good, otherwise you need to upgrade either your browser,  your operating system or both.

Why are we doing this

We are required to turn off TLS 1.0 and lower support in order to comply with PCI regulations and to ensure high security.  PCI regulations are required to be adhered to in order to accept credit cards.  As an ecommerce site provider this is critically important for us and for you our merchants.  We have waited as long as possible to turn this off to give clients time to upgrade and now we must proceed.

Questions

If you have any questions or concerns feel free to contact us via support request or via email at support@storesecured.com or you can read further at the link below:

https://www.pcisecuritystandards.org/pdfs/PCI_SSC_Migrating_from_SSL_and_Early_TLS_Resource_Guide.pdf

Advertisements

%d bloggers like this: